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Introduction 

VLC Media Player 
The VLC Media player (VLC) is software used to play different formats audio and video from a disk. It can 
also be used to stream audios from your local disk on the network or on the internet.  

Features of VLC Media Player 
The following are the features of the VLC Media Player: 

• Multiple Formats 
VLC supports multiple audio and video formats. It is compatible with multiple operating systems 
(Windows, Mac and Linux). Supported formats depend on the operating system on which the 
media is being rendered.  

• Volume  
VLC allows you to set volume that is 300 percent higher than your machine volume setting. 
Thus, it enhances your listening experience. In addition, you can connect VLC to your home 
speakers wirelessly using AirTunes. 

• Customizable User Interface 
You can select icons for the most frequently used functions and choose to hide the rest of the 
buttons and icons. You can also choose a theme from the available skins provided with the 
package. 

• Playback 
Unlike typical playback, VLC offers a frame by frame Playback which allows you to rewind or 
forward your audio or video by a small fraction of time. 

• Blu-ray and HD 
VLC contains encoders that support high-definition audio and video formats. So, you can play 
Blu-ray or HD DVD videos on the player without interruptions. 

VideoLAN Project 
VLC media player is a product part of the VideoLAN project that produces free software for multimedia, 
released under the General Public License. It became open-source in 1996, and since then has been 
improvised by several developers from over 20 countries. 

Being open-source, VLC is free to download and install. VLC code can be integrated with other software 
or web based applications. This provides great flexibility in usage. You can contribute code, money, 
documentation, and useful material to the project. You can visit http://www.videolan.org/videolan/ for 
more information. 

  

http://www.videolan.org/videolan/


Getting Started 
VLC Media player is an open-source freeware that can be installed on various operating system 
platforms. Owing to its support to multiple operating systems and media formats, VLC is commonly used 
in personal and professional environments. 

VLC can be installed using an installer or through the command line interface depending upon the 
operating system on which it is being installed. In this section we will see the installation process on a 
Windows environment. 

Prerequisites 
Before you begin with the installation, check whether your system meets the following requirements: 

Table 1: System Requirements 

Component Required Recommended 

Operating system Microsoft Windows® XP Home 
Edition, Windows XP 
Professional, or Windows XP 
Media Center Edition 

Windows XP Home Edition, 
Windows XP Professional, or 
Windows XP Media Center 
Edition 
Windows XP Service Pack 2 
Windows Media Player 10 works 
best with the latest software 
version of the Player and 
operating system. 

Processor A 233 megahertz (MHz) 
processor, such as an Intel 
Pentium II or Advanced Micro 
Devices (AMD) processor 

A 1.5 gigahertz (GHz) processor 
or faster, especially if you intend 
to synchronize video files to your 
portable device 

RAM 64 megabytes (MB) 1 gigabyte (GB) 

Free hard disk space 100 MB 1 gigabyte (GB) 

Sound output device Speakers or headphones 5.1 multichannel speakers 
For more information about 
device compatibility, see the 
documentation for your sound 
card. 

Installation 
You will need to download an executable file to install VLC on your system. You can download vlc-
<version>-win<bit>.exe from http://www.videolan.org/vlc/download-windows.html. Save this file on 
the local disk and perform the following steps: 

1. Open the executable by double clicking on the downloaded file (vlc-<version>-win<bit>.exe).  

http://www.videolan.org/vlc/download-windows.html


2. The setup will unpack and the Installer Language panel is displayed. Select the language of your 
choice and click OK. 

3. The VLC Media Player setup panel is displayed. Click Next to continue. 
4. Review the License terms and conditions carefully and click Next to proceed with the 

installation. 
5. On the next panel, you will choose the type of installation. 

 

Figure 1: Selecting Type of Installation 

You can choose the option Recommended from the drop-down list, for best results. However, 
you can choose to customize the installation using Custom installation. In this, you can check 
required components and uncheck the remaining components. Only checked components will 
get installed. Selecting Full will install check all components provided in the list and selecting 
minimum will install only the mandatory components. 

6. Click Next. 
7. Choose the install location on the next panel by entering the path in the textbox provided. 



 

Figure 2: Choose Install Location 

8. Click Install. 
9. Click Finish to complete the installation process. 

Uninstallation 
On a Windows operating system, you can uninstall VLC from the Control Panel. 

1. Go to the Control Panel > Programs > Uninstall a Program. 
2. Search for VLC media player and click Uninstall/Change. 

 

Figure 3: Uninstall VLC Media Player 



3. On the VLC Media Player Uninstall panel, click Next. 
4. On the next panel, choose the components that you want to uninstall. Click Uninstall. 
5. The VLC Media player will be removed from your system. Click Finish to exit. 

Functions with Media 
The VLC Media Player has in-built codecs for most of the audio and video formats. Hence, it supports a 
wide range of video and audio types. 

Following is a list of the supported formats: 

Table 2: List of Supported Media formats 

Video Formats Audio Formats 
MPEG-1/2 MPEG Layer 1/2 
DIVX (1/2/3) MP3 - MPEG Layer 3 
MPEG-4 ASP, DivX 4/5/6, XviD, 3ivX D4 AAC - MPEG-4 part3 
H.261 Vorbis 
H.263 / H.263i AC3 - A/52 (Dolby Digital) 
H.264 / MPEG-4 AVC E-AC-3 (Dolby Digital Plus) 
Cinepak MLP / TrueHD">3 
Theora DTS 
Dirac / VC-2 WMA 1/2 
MJPEG (A/B) WMA 3 1 
WMV 1/2 FLAC 
WMV 3 / WMV-9 / VC-1 1 ALAC 
Sorenson 1/3 (Quicktime) Speex 
DV (Digital Video) Musepack / MPC 
On2 VP3/VP5/VP6 ATRAC 3 
Indeo Video v3 (IV32) Wavpack 
Indeo Video 4/5 (IV41, IV51) Mod (.s3m, .it, .mod) 
Real Video 1/2 TrueAudio (TTA) 
Real Video 3/4 APE (Monkey Audio) 
MPEG-1/2 Real Audio 2 
DIVX (1/2/3) Alaw/µlaw 
MPEG-4 ASP, DivX 4/5/6, XviD, 3ivX D4 AMR (3GPP) 
H.261 MIDI 3 
H.263 / H.263i LPCM 
 
In this section we will see the operations that can be performed on a media file using VLC. 

Playing Media Present on the Disk 
VLC can play media which is on the disk, or on the network. There are two ways to play a media present 
on the disk. 



Open file location 
To open media on the disk perform the following actions: 

1. From the Media menu, click Open File Location. 

 

Figure 4: Open file location 

2. Browse the required file and click Open. 

 

Figure 5: Open file 



You can also filter the type of files to be displayed using the filter drop-down list. 

The file will start playing in the VLC Media player. 

Drag and drop file 
Alternatively, you can drag and drop the video file to the player in order to play the file. To do so: 

1. Open VLC Media Player. 
2. Browse to the file location on your disk. 
3. Click the required file and drag it on to the VLC. 
4. Drop the file.  

The media file will begin playing in the player. 

Playback Options 
The playback functions of the VLC Media Player can be done in two ways: 

• The Playback Menu 
• The Playback Control Buttons 

 

Figure 6: Playback options 

 

 

 



Table 3: Playback options 

Playback Menu Item Playback Buttons Function 

 

 

 

 

 
Play a paused or 
stopped file. 

 

 
 

 

 

 
Stop a file. 

 

 
 

 

 

 
Go back to the 
previous file 

 

 
 

 

 

 
Skip to the next file 

 

 
 

 
 
 
 
--- 

 
Increase or 
decrease the speed 
of the video by a 
certain amount. 

Viewing Subtitles 
VLC supports subtitles in multiple languages. You can set the text preferences like font size and font type 
for subtitles. 

 

Figure 7: Enabling subtitles 

 The subtitles track is disables by default. To enable subtitles perform the following actions: 

1. Click Subtitle > Add Subtitle file. 
Note: You can add the subtitle file only if the video file is open in the player.  

2. Browse and select the required subtitle file. 
Subtitles will be displayed along with the video.  



You can choose to hide the subtitles at any point in time by clicking the Subtitle > Sub Track > Disable 
button. Additionally you can also customize the format of subtitles by clicking on Tools > Preferences > 
Subtitles/OSD.  

 

Figure 8: Customizing subtitles 

Setting-up a Playlist 
VLC allows you to setup a playlist to play videos or songs in a particular sequence 

To make a new playlist: 

1. Access the current playlist from View > Playlist. 
2. Right click in the list section of the playlist. 

 

Figure 9: Add playlist 

3. Click on the Add File or Add Folder menu. A dialog box to select files is displayed. Select files and 
click OK. 



4. Right click and select Save Playlist to file to save the playlist for later use. 
Your playlist is saved to the desired location.  

You can use three options to play your playlist. They are given below: 

Table 4: Playlist options 

 

 
 

 
This option is used to toggle between items 
in the playlist. 

 

 
 

 
This option enables you to toggle between 
loop all, loop once and no loop 

 

 
 

 
This option is used to play random files from 
the playlist. 

Recording Media 
You can record a part or the entire video that is being played in the VLC Media Player. To do so, perform 
the following actions: 

1. Click on View > Advanced controls to display recording controls on the toolbar. 

 

Figure 10: Enable recording controls 

The recording control will be displayed. 
2. To start a recording click the Record button. 

 
3. To stop the recording, again click Record. 
4. Access the recorded video from C:\Users\<your_Account>\Videos. 



Configuring VLC Media Player 
As VLC is open-source, it can be customized to your requirement. This can be done through command-
line or code. However, VLC provides a wide range of options to customize your media player through the 
tool. To modify the settings go to Tools > Preferences. 

The Simple Preferences dialog box is displayed. 

 

Figure 11: Customizing VLC 

Through this you can make changes with respect to: 

•  Interface 
• Audio 
• Video 
• Subtitles (Refer to <<<<add bookmark>>>>) 
• Inputs/Codecs 
• Hotkeys 

The following section covers these settings in more detail. 

Interface Settings 
The Interface tab allows you to change the look and feel of the media player. 

Language 

 

Function: Allows you to select the Menu language. 

Default Value: Auto (English) 



Look and Feel

 

Function: Allows you to set the theme and control settings of the player. You can select a custom skin. 
Custom skins are available on the VLC website for free download. 

Default Value: Native style is the default theme. 

Playlist and Instances 

 

Function: Allows you to select the number of instances to be played parallel.  

Default Value: Uses only once instance but allows multiple. 

Privacy/Network Interaction 

 

Function: Allows you to define settings of the player when system is connected to the network 

Default Value: VLC checks for updates every three days. 

Operating System Integration 

 

Function: Allows you to select the extensions you want VLC to open by default.  



Default Value: Files with the extensions 3ga, 669, amr, amv, avi, divx, flv, gvi, mkv, mka, mpeg, ogg, and 
rm. 

Audio  
The Audio tab allows you to configure audio settings. You can enable or disable the audio completely by 
checking or un-checking the checkbox provided. 

Volume 

 

Function: Allows you the set the initial value for volume. 

Default Value: 100% 

Output 

 

Function: VLC uses a modular system, which allows you to add new functions and formats. You can 
select the required module from the options provided in the drop-down menu. 

Default Value: Automatic. 

Effects 

 

Function: Allows you to edit the sound quality of the audio or video file being played. 

Default Value: Dolby is enabled and Visualization is disabled. 

Tracks 

 



Function: Allows you to set the language of the audio track that you choose to play. In order to save 
tracks, you will need to enter your account username and password. 

Default Value: Blank. 

Video 
This tab allows you to edit the video quality of the file being played in the media player.  

Display 

 

Function: Allows you to define the overlay settings and initial location of the player. 

Default Value: Selects the best method available for display. 

DirectX 

 

Function: Allows you to select the name of your display machine in a multiple-monitor configuration.  

Default Value: The default display is your own machine name. 

Video 

 

Function: Allows you to define settings for video processing. 

Default Value: Deinterlacing is off. 

Snapshots 

 



Function: Allows you to define settings to save snapshots.  

Default Value: Snapshots are saved in My Documents > Pictures. 

Using VLC for Streaming 
The VLC Media Player can be used as a server to send a stream or as a client to receive and display a 
stream of audio or video. Once you create a stream, it can be broadcasted to multiple clients. This 
feature of VLC, combined with the Capture device can also be used as for video conferencing.  

This section describes the process of streaming a video on the network. 

Create Stream 
To stream a video on the network you will need to create a stream and define the protocol to be used 
for streaming. To create a stream, perform the following steps: 

1. Open VLC Media Player. 
2. Go to Media > Stream. 
3. Click Add to add the file to be streamed. 

 
4. Browse and open the required file. Click Stream to start streaming. 
5. The Source panel will display the file path of your file. Verify the path and click Next. 
6. Choose the protocol to be used for streaming.  



 
In this example, the RTP network protocol is used. Click Add. 

7. On the next screen, provide the host IP Address and port number.  

 
Click Next to continue. 

8. Select the transcoding options. You can select options for Video and Audio. Click Next. 



9.  The summary screen is displayed.  

 
The output string includes the values that you have entered in the earlier screens. Verify the 
settings and click Stream. 

Streaming will begin. This is the host machine. You will need a client machine to capture and display this 
stream. 

Play Stream 
A stream broadcasted on the network can be played using a client computer with the VLC Media player 
installed on it. This section covers the steps to display the stream broadcasted by the VLC player from 
windows machine using the RTP network protocol. To play these stream follow the steps: 

1. Open VLC Media Player. 
2. Go to Media > Open Network Stream. 

The Open Media dialog box is displayed. 
3. Enter the syntax and values for streaming. 

In this example, the RTP Protocol is used. You will need to enter the IP address of the server 
machine followed by a colon and the port number.  



 
4. Click Play. 
5. The streamed video is displayed in your VLC Media Player.  

 



Accessing help 
Being open source, Help for VLC Media Player is available online in the form of wikis. To access help click 
F1 or got to Help > Help. 

The Help window is displayed through which you can access online help information links. 

 

Figure 12: VLC Help 

  



Appendix A: Shortcuts 
Shortcuts or Hotkeys can be used to operate VLC tasks using the keyboard.  Shortcuts are built-in, but 
can be customized as per your need.  

To customize: 

1. Go to Tools > Preferences > Hotkeys. 
2. Double click on the hotkey to be modified. 

 
3. Click Unset to clear this Hotkey or click the required key combination to overwrite this hotkey. 
4. The new hotkey will be saved and is displayed in the table provided. 

 

 

 



Following is the list of default Hotkeys: 

F Fullscreen 
Space Pause or play movie 
V Subtitles on/off (or s) 
B Audio track cycle 
Ctrl+Arrow Up/Ctrl+Arrow Down Volume 
Double click Fullscreen 
Scroll Volume or Position (see settings) 
Right click Local menu (play controls, audio/video) 
Ctrl+D Open disc menu 
Ctrl+F Open folder (browse folder menu) 
Ctrl+R/Ctrl+S Advanced open file 
Ctrl+O Open single file(s) 
M Mute and unmute audio 
P Play movie (from the very beginning) 
S Stop movie 
Esc Exit full screen mode 
[+]/-/= Faster, slower, normal 
A Aspect ratio 
C Crop screen 
G/H Decrease subtitle delay / Increase subtitle delay 
J/K Decrease audio delay / Increase audio delay 
Z Change zoom mode 
Ctrl+1, Ctrl+2, Ctrl+3, Ctrl+4 Recent media (in Media - Recent media menu) 
T Show time 
Ctrl+T Goto time 
E Next Frame. Advance forward frame-by-frame 
Ctrl+D Open disc menu 
Ctrl+F Open folder (browse folder menu) 
Ctrl+R/Ctrl+S Advanced open file 
Ctrl+O Open single file(s) 
M Mute and unmute audio 
P Play movie (from the very beginning) 
S Stop movie 
Esc Exit full screen mode 
[+]/-/= Faster, slower, normal 
A Aspect ratio 
C Crop screen 
G/H Decrease subtitle delay / Increase subtitle delay 
J/K Decrease audio delay / Increase audio delay 
Z Change zoom mode 
Ctrl+1, Ctrl+2, Ctrl+3, Ctrl+4 Recent media (in Media - Recent media menu) 
T Show time 
Ctrl+T Goto time 
E Next Frame. Advance forward frame-by-frame 
Shift+Arrow Left/Arrow Right Very short jump (3 seconds) 



Alt+Arrow Left/Arrow Right Short jump (10 seconds) 
Ctrl+Arrow Left/Arrow Right Medium jump (1 minute) 
Ctrl+Alt+Arrow Left/Arrow Right Long jump 
Shift+Arrow Left/Arrow Right Very short jump (3 seconds) 
Alt+Arrow Left/Arrow Right Short jump (10 seconds) 
Ctrl+Arrow Left/Arrow Right Medium jump (1 minute) 
Ctrl+Alt+Arrow Left/Arrow Right Long jump 
Ctrl+H Hide / unhide controls 
Ctrl+P Preferences/ interface settings 
Ctrl+E Adjustments and audio/video effects 
Ctrl+B Edit bookmarks 
Ctrl+M Open messages 
Ctrl+N Open network 
Ctrl+C Open captue device 
Ctrl+L Open playlist 
Ctrl+Y Save playlist 
Ctrl+I/Ctrl+J Media information 
Alt+A Open audio menu 
Alt+H Open help menu 
Alt+M Open media menu 
Alt+P Open playlist menu 
Alt+T Open tool menu 
Alt+V Open video menu 
Alt+L Open playback menu 
D Show movie path 
N Play next movie from playlist 
F1 Show Help 
F11 Window full-screen (not equal to pressing F) 
Alt+F4, Alt+q or Ctrl+Q Quit VLC 
Shift+S Take a Snapshot / Screenshot 
Ctrl+H Hide / unhide controls 
Ctrl+P Preferences/ interface settings 
Ctrl+E Adjustments and audio/video effects 
Ctrl+B Edit bookmarks 
Ctrl+M Open messages 
Ctrl+N Open network 
Ctrl+C Open captue device 
Ctrl+L Open playlist 
Ctrl+Y Save playlist 
Ctrl+I/Ctrl+J Media information 
Alt+A Open audio menu 
Alt+H Open help menu 
Alt+M Open media menu 
Alt+P Open playlist menu 
Alt+T Open tool menu 
Alt+V Open video menu 
Alt+L Open playback menu 



D Show movie path 
N Play next movie from playlist 
F1 Show Help 
F11 Window full-screen (not equal to pressing F) 
Alt+F4, Alt+q or Ctrl+Q Quit VLC 
Shift+S Take a Snapshot / Screenshot 
 

  



Glossary 
This section defines some technical terms used throughout the doscument. 

open source 

network protocol 

stream 

architecture 

interlacing 

interleaving 
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